InfoAjuda

Projeto 4 - Codigo (Algoritmo)

Projeto 4 - Codigo (Algoritmo)
« Online: Outubro 26, 2017, 11:29:09 pm »
Citar
algoritmo "Diego Barbosa"
   Var
   cont, alunos: inteiro
   mensalidade, desconto, valor: real
   turno, categoria : caractere
inicio
      alunos <- 0
      mensalidade <- 0
      para cont de 1 ate 5 faca
           enquanto (mensalidade<=0) faca
                escreval("Digite o valor da mensalidade")
                 leia (mensalidade)
                  se (mensalidade<=0) entao
                   escreval("Valor invalido.")
                fimse
           fimenquanto
           
           enquanto ((turno<>"M") E (turno<>"T") E (turno<>"N")) faca
                    escreval("Informe seu turno")
                    escreval("M - para manhã")
                    escreval("T - para tarde")
                    escreval("N - para noite")
                    leia(turno)

                    se ((turno<>"M") E (turno<>"T") E (turno<>"N")) entao
                         escreval ("Turno invalido.")
                         escreval("")
                    fimse
           fimenquanto
           
           enquanto ((categoria<>"B") E (categoria<>"N")) faca
               escreval("Informe sua categoria")
               escreval("B - para renda baixa")
               escreval("N - para renda normal")
               leia(categoria)
               se ((categoria<>"B") E (categoria<>"N")) entao
                    escreval("Categoria invalida.")
                    escreval("")
               fimse
           fimenquanto

          se(categoria="N") entao
             alunos <- alunos + 1
          fimse

          valor <- mensalidade
         
          se(turno="T") entao
              desconto <- mensalidade * 0.05
               valor <- mensalidade - desconto
          fimse

          se(turno="N") entao
               desconto <- mensalidade * 0.10
              valor <- mensalidade - desconto
          fimse

          se categoria="B" entao
               desconto <- valor * 0.10
               valor <- valor - desconto
          fimse


          escreval("Mensalidade: ", valor, " R$")
          escreval("Valor total do curso: ", valor*12)
          valor <- 0
          desconto <- 0
          categoria <- ""
          mensalidade <- 0
          turno <- ""
      fimpara

      escreval("O numero de alunos com renda normal e:", alunos)
      escreval("O numero de alunos com renda baixa e:", 5-alunos)

fimalgoritmo
« Última modificação: Novembro 15, 2017, 03:12:56 pm por DiegoB. »

Re:Projeto 4 - Codigo
« Resposta #1 Online: Outubro 30, 2017, 11:56:12 pm »



Você já executou este codigo? ele fica em loop e não executa corretamente
« Última modificação: Outubro 31, 2017, 08:17:37 pm por DiegoB. »

Re:Projeto 4 - Codigo
« Resposta #2 Online: Outubro 31, 2017, 08:04:58 am »
Citar
Você já executou este codigo? ele fica em loop e não executa corretamente

Peço que teste novamente, pois o loop que o programa faz é apenas o solicitado no enunciado, ou seja ele repete 5 vezes para efetuar o calculo dos 5 alunos solicitados.


Re:Projeto 4 - Codigo
« Resposta #3 Online: Outubro 31, 2017, 09:35:48 pm »