InfoAjuda

Código Projeto 4 (Algoritmo)

Código Projeto 4 (Algoritmo)
« Online: Novembro 01, 2017, 11:27:00 am »
Citar
algoritmo "Projeto 4"

var
    mensa : vetor [1..5] de real
    turno, aluno: vetor [1..5] de caractere
    cont, contb, contn : inteiro
inicio

//INFORMANDO VALOR
cont := 0
para cont de 1 ate 5 faca
escreval("DIGITE O VALOR DA MENSALIDADE DO",cont,"º ALUNO")
escreva ("R$ ")
leia (mensa [cont])
// CASO DIGITE INFORMAÇÃO INCORRETA
enquanto (mensa[cont] <= 0) faca
escreval
escreva ("VALOR INVÁLIDO, DIGITE O VALOR DA MENSALIDADE: R$ ")
leia (mensa[cont])
fimenquanto
limpatela
//INFORMANDO TURNO
escreval("          DIGITE O TURNO DO CURSO")
escreval("M para Manhã | T para Tarde | N para Noite")
escreva("TURNO DO" ,cont, "º ALUNO: ")
leia (turno[cont])
// CASO DIGITE INFORMAÇÃO INCORRETA
enquanto ((turno[cont] <> "M") e (turno[cont] <> "T") e (turno[cont] <> "N")) faca
escreva ("TURNO INVÁLIDO, DIGITE M, T OU N: ")
leia (turno[cont])
fimenquanto
limpatela
//INFORMANDO CATEGORIA DE ALUNO
escreval("      DIGITE A CATEGORIA DO ALUNO")
escreval("B para Baixa Renda | N para Renda Normal")
escreva("CATEGORIA DO" ,cont, "º ALUNO: ")
leia (aluno[cont])
// CASO DIGITE INFORMAÇÃO INCORRETA
enquanto ((aluno[cont] <> "B") e (aluno[cont] <> "N")) faca
escreva ("CATEGORIA DO ALUNO INVÁLIDA, DIGITE B OU N : ")
leia (aluno[cont])
fimenquanto
limpatela
//CONTADOR DE CATEGORIA
se (aluno [cont] = "B") entao
contb := contb + 1
senao
se (aluno [cont] = "N") entao
contn := contn + 1
fimse
fimse
fimpara
// CALCULO DOS VALORES
cont := 0
para cont de 1 ate 5 faca

se (aluno[cont] = "B") e (turno[cont] ="M") entao
     escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ",mensa[cont]-mensa[cont]*10/100:8:2)
senao

se (aluno[cont] = "B") e (turno[cont] ="T") entao
   escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ", mensa[cont]-mensa[cont]*15/100:8:2)
senao

se (aluno[cont] = "B") e ((turno[cont] ="N")) entao
     escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ", mensa[cont]-mensa[cont]*20/100:8:2)
senao

se (aluno[cont] = "N") e (turno[cont] ="M") entao
     escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ", mensa[cont]:8:2)
senao

se (aluno[cont] = "N") e (turno[cont] ="T") entao
   escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ", mensa[cont]-mensa[cont]*5/100:8:2)
senao

se (aluno[cont] = "N") e ((turno[cont] ="N")) entao
     escreval ("VALOR DA MENSALIDADE DO" ,cont, "º ALUNO: R$ ", mensa[cont]-mensa[cont]*10/100:8:2)
fimse
fimse
fimse
fimse
fimse
fimse
escreval("VALOR TOTAL DO CURSO DO" ,cont,"º ALUNO: R$ ", mensa[cont]*12:8:2)
escreval("----------------------------------------------")
fimpara
escreval ("ALUNOS DE BAIXA RENDA SÃO: ", contb)
escreval ("ALUNOS DE RENDA NORMAL SÃO: ", contn)

fimalgoritmo
« Última modificação: Novembro 15, 2017, 03:12:20 pm por DiegoB. »