InfoAjuda

Desafio Algoritimos

Desafio Algoritimos
« Online: Outubro 17, 2017, 02:43:32 pm »
segue alguns algoritmos do desafio criado por nosso amigo Wanderson.
conforme for terminando outros estarei atualizando, caso alguém consiga terminar tbem pode ir postando para atualizarmos a lista.

os desafios serão postados na ordem da lista proposta no zap.

Desafio n° 1
Código: [Selecionar]
algoritmo "desafio1"
// Data : 17/10/2017
// Seção de Declarações
var
 a, b, temp :inteiro
inicio
// Seção de Comandos
   a := 10
   b := 20
   temp := 20
   
   escreval ("a variavel a = ", a)
   escreval ("a variavel b = ", b)
   
   
   escreval ("")
   escreval ("Alterando Variaveis.")
   escreval ("Processando.")
   escreval ("Processando...")
   escreval ("Processando.....")
   escreval ("Processando........")
   escreval ("Processando..........")
   escreval ("")
   
   b := a
   a := temp
   
   escreval ("a variavel a = ", a)
   escreval ("a variavel b = ", b)
   
fimalgoritmo

Desafio n°2
Código: [Selecionar]
algoritmo "desafio2"
// Data : 17/10/2017
// Seção de Declarações
var
 valor :real
inicio
// Seção de Comandos
   escreval ("Digite um valor qualquer")
   leia (valor)
   escreval ("O numero anterior ao valor escolhido é ", valor-1)
   escreval ("O numero posterior ao valor escolhido é ", valor+1)

fimalgoritmo

Tags: desafios